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VISIPAY.NET – EMPLOYEE SELF SERVICE (ESS) FOR VISIPAY ADMINISTRATORS 

GETTING STARTED 

Make sure the following has been set up by either PBT IT services or the company’s IT people who have used the 

notes provided: 

1. Outlook or another mail program is setup on the Visipay computer. 

2. The ESS website is setup. Make sure that: 

 HTTPS and SSL Certificate has been discussed with IT services  

 IIS7 (or higher) Windows feature has been installed and enabled with Visipay ESS files. 

 DotNet framework 4.5 has been installed. 

 SQL Server 2008 (or higher) has been installed. 

 MVC 3 has been installed (only for ESS web site). 

 MIME Type has been setup so Video plays. 

 Loading of website has been tested. 

3. Visipay.Net is setup as follows: 

 Visipay.Net (12.55 or higher) is installed with Administration Tools. 

 A Visipay.Net Common database has been created. 

 A Visipay.Net Company database has been created. 

 web.config has been configured for the Company Database and Common database. 

 A Visipay.Net license that supports using the web has been bought. This licence must have as many users as 

there are employees who will use ESS. 

 All employee records have been setup including records for administrators and leave approval officers. 

For more information see: http://www.asp.net/mvc and VisipayESS Setup Guide.docx. 

  

http://www.asp.net/mvc%20and%20VisipayESS%20Setup%20Guide.docx
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EMPLOYEE SELF SERVICE MODULE, ADMINISTRATION MODULE, LOOKUPS AND PAY PROCESSING 

General Information:  

Each leave approval officer needs to be linked to a leave approval group. 

Each employee within Visipay.NET needs to be attached to an approval group.  

Each employee within Visipay.NET needs to be assigned a user login, which in turn is assigned a user role that defines 

their privileges. 

This section also includes documentation on how to add and delete Leave Types, add Leave Types to Staff Types, 

change Leave Options, change Visible Leave Accruals options, add Public Holidays, use the Leave Calendar, modify 

employee records and processing approved leave in the pay run. 

ADDING AND DELETING APPROVAL GROUPS BASED ON MANAGEMENT HIERARCHY 

1. Adding an Approval Group 

 Click Approval Groups on the Self Service tab. 

 

 Click the Right mouse button in the blank area under Title 
then click Add with the Left mouse button. 

 

 Enter a title for Leave Approval Group. 

 Click on the drop arrow to choose the employee who is the 
Approval Officer. 

 Click on the drop arrow to choose the employee who is the 
Delegate Approval Officer. 

NB: if the Approval Officer is away you need to tick the ‘Away’ 
box so that leave requests go to the Delegate Approval Officer. 

Employees for Processing are not added here; you need to add 
the Approval Group to the employee’s record. See page 11. 

 Click OK. 

 Create a second Approval Group (if required). 

 Click Close to get out of the Leave Approval Group List.  

 

2. Deleting an Approval Group 

 Click the Right mouse button on the Approval Group then 
click Delete with the Left mouse button if there are no 
employees attached to the Approval Group. 
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ADDING LEAVE TYPES 
 

3. Adding Leave Types (if required) 

 Click on the drop arrow under the Program Wheel then click 
Lookups…. 

 Click Leaves.  

 Click the Right mouse button in the blank area under existing 
Leaves then click Add with the Left mouse button to add a 
new Leave. 

 

 Give the New Leave a Title and Description then click on the 
drop arrow to choose a Leave Type – either Annual Leave, 
Long Service Leave, Personal Leave or Rostered Day Off. 

 

4. Deleting Leave Types 

 Click on the drop arrow under the Program Wheel then click 
Lookups…. 

 Click Leaves. 

 Click the Right mouse button on the Leave then click Delete 
with the Left mouse button. 

NB: You can only do this if there are no employees attached to 
the Leave. 
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5. Adding Leave Types to Staff Types 

 Click on the drop arrow under the Program Wheel then click 
Lookups…. 

 Click Staff Types. 

 Click the Right mouse button on the Staff Type then click Edit 
with the Left mouse button. 

 

 Click the Right mouse button in the blank area under existing 
Leave Types then click Add with the Left mouse button to 
add a new Leave Type. 

NB: A leave type such as Compassionate leave does not accrue 
any days but if you want employees to be able to apply for 
compassionate leave on the ESS website it needs to be set up as 
a leave accrual. 

 

CHANGING LEAVE OPTIONS 
 

6. Changing Leave Options – Enable e-mail notification, 
Approver away, Leave balances in days and ESS URL  

 Click on Leave Options on the Self Service tab. 

 On the Options tab Tick ‘Enable e-mail notification’ so that 
employees will get an email telling them whether their leave 
has been approved or rejected. 

 Tick ‘Allow approver to approve while away’ if you want an 
approver to be able to respond to leave requests when the 
approver is out of the office. 

 Tick ‘Show employee leave balances in days’ if you want to 
display balances in days instead of hours. 

 Type in the website address that employees and approvers 
will use to access ESS on the Internet. 
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7. Changing Visible Leave Accruals options 

 On the Visible Leave Accruals tab tick each type of accrued 
leave to change the visibility on the website of the different 
Leave Types. 

NB: Even if employees can’t see their leave accruals they can still 
apply for any Leave Type that has been set up in their Staff Type. 

 

8. Adding, Editing and Deleting Public Holidays 

It is important to review and set up all national and local Public 
Holidays. When employees apply for leave and Public Holidays 
fall within the chosen date range, Visipay will automatically 
calculate the number of days leave to be taken excluding Public 
Holidays. 

 Click on the Public Holidays (All Pay Locations) tab. 

 If necessary, click on the + next to a year to display the 
standard public holidays for that year. 

 Click the Right mouse button on one of the holidays and click 
Add with the Left mouse button to create a new Public 
Holiday, Edit to change the name and/or the date of the 
Public Holiday or Delete to remove the Public Holiday. 

NB: This can also be done for individual Pay Locations by clicking 
on the drop arrow under the Program Wheel then clicking 
Lookups…., Pay Locations. When you edit a Pay Location you can 
click the Right mouse button to Add a Public Holiday for that 
Location. 

 

USING THE LEAVE CALENDAR 
 

The Leave Calendar shows all employees in a style that looks similar to Microsoft Outlook. There are a range of 
different views and the employee list can be filtered and sorted. You can also print the calendar and add frequently 
used icons to the Quick Access toolbar. 

 Click Leave Calendar on the Self Service tab. 

NB: The Leave Calendar is only available within the Visipay 
program; it is not available on the ESS website. 
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9. The Home tab 

 

 Click on Gantt View or Timeline View. 

Employees are displayed on the left hand side and the months, 
days and hours are displayed along the top. 

 Click the Backward or Forward icons to see different weeks 
of the year. 

 Click the Zoom In icons several times to see the hours of a 
day or click the Zoom Out icons several times to see the 
months. 

 

 Click the Arrange icons to see a Day View, Work Week View, 
Week View or Month View. 

NB: Employees are now displayed along the top and hours are 
displayed on the left hand side. 

 

 If you have many employees and they are not all being 
displayed in the Calendar click several times on the ‘-‘ sign in 
the bottom right hand corner of the employee list. The 
employees then become visible. Use the scroll bar or the 
scroll arrows to see the rest of the employees. 

 

 To further limit the list of employees, click on the Sort Filter 
Panel on the Home tab if it is not already highlighted. The 
Panel appears at the bottom of the screen. 

 Click on the next to And to create a new filter. 

 Click on Apply Filter. 
 

 To sort the list of employees by Last Name, First Name, Code, 
Department, Staff Type or Location click on the drop arrow 
to choose one of them and then click Apply Sort. 

 

10. The View tab 

The View tab has some of the same icons as the Home tab. 
However it also has a Time Scale which allows you to see the 
hours on the left hand side in increments of 60, 30, 15, 10, 6 and 
5 minutes. It also lets you view just the Working Hours instead of 
the whole day. 
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11. The File tab 

The File tab allows you to Print Preview, Quick Print or Page 
Setup the current Calendar view. 

You can also close the Leave Calendar here instead of clicking 
the X in the top right hand corner.  

12. The Quick Access Toolbar 

You can add frequently used Leave Calendar icons to the Quick 
Access Toolbar. 

 Click the Right mouse button on any icon then click Add to 
Quick Access Toolbar with the Left mouse button. 

 

 

MAINTAINING EMPLOYEE SECURITY THROUGH USER ROLES 

13. Creating user roles 

 Click Roles on the Administration tab. 

 

 Click the Right mouse button in the blank area under existing 
roles then click Add with the Left mouse button. 

 

 Give the role a title and description. 

 Tick ‘Applies To User Employee’. NB: Make sure that Access 
All Employees is not ticked unless the employee is an 
Administrator who has the right to view all employees. 

 Under Employee Rights tab choose what you want 
employees to be able to see on the ESS website.  

Under Access tick Leave Accruals and Leave History (if they are 
eligible for Leave) and you may also want them to be able to see 
their Payment Summaries and Payroll History (pay slips).  

NB: These are the only options that are currently available on the 
ESS website. 

Important: You should not allow employees to Add or Delete. 
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Optional: 

You may want users to login to the Visipay program so that they can change their bank details, super, dependents 
and other details. These are not yet available on the ESS website but are scheduled for future development. 

When users log in to the Visipay program they will only be able to see their own employee card details if you ticked 
‘Applies To User Employee’. 

14. Deleting user roles 

 Click the Right mouse button on the role then click Delete 
with the Left mouse button. 

 

MAINTAINING EMPLOYEE SECURITY THROUGH USER LOGINS 

15. Creating user logins 

 Click Users on the Administration tab. 

 

 Click the Right mouse button in the blank area under User 
Name then click Add with the Left mouse button. 

 

 Assign Roles that are appropriate for the User – a user can 
have more than one Role but they must have a Role that 
enables them to see at least one of the options that are 
currently available on the ESS website i.e. their Leave 
Accruals, Leave History, Payment Summaries and Payroll 
History if appropriate. 

 

16. Deleting user logins 

 Click the Right mouse button on the Login name then click 
Delete with the Left mouse button. 
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CHANGING EMPLOYEE RECORDS SO THAT EMPLOYEES CAN USE ESS 

17. Modifying employee records 

 Edit the first employee card by double clicking on the 
employee. 

 Under the Personal tab make sure that the employee has a 
valid email address. 

NB: Unless the employee has an email address they will not be 
immediately informed if their leave has been approved or 
rejected. 

 

 Under the Employment tab change the Approval Group in 
Leave Management based on management hierarchy. 

 

PROCESSING APPROVED LEAVE IN THE PAY RUN 
 

Once a leave approval officer has approved an employee’s leave the pay needs to be processed. You can check the 
Leave Calendar to see whether a leave has been approved or rejected. You can also see that leave approvals are 
available when you in the Processing Pay screen. 

 Click Process Pays. 

NB: Processing approved leave is usually done in the normal pay 
run. 

 

 Choose the employee(s) to be paid. 

 Click OK. 

 Make sure that the pay processing dates are correct and click 
OK. 

 

 A message will appear at the bottom of the screen saying 
that ‘Leave approvals are available for this employee’ if the 
employee has had their leave approved. 

 Double click anywhere on the yellow message bar to archive 
leave approvals or view which ones to enter on the 
Processing Pay screen. 
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 Click process. 

This will not put the leave hours in the pay it will just remove the 
information from the Approved Leave box. 

 

 Click on Add Earnings. 

 

 Click the correct Leave earning and change the quantity 
(hours). 

 Change the Leave Details to reflect the date range of the 
Leave. 

 

 Modify the pay to reduce the quantity of the Normal Pay by 
the Leave hours.  

 Process the pay.  
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APPENDIX 

TIPS AND TRICKS 

The requester submitted the request after the 
leave was taken.  Can this still be entered and 
approved to reflect correct leave balances? 

Yes. 

The leave was requested, approved and paid 
however it didn’t happen.  How do I fix this? 

If the leave request has been processed through the payroll and 
then later that leave request is cancelled, then it will not 
automatically adjust the employee’s leave accrual. When you 
process a leave request through the payroll, you have to manually 
add the leave pay item. So, in this case where the leave request 
has been cancelled after it has been approved and processed, the 
employee’s leave accrual has to be manually adjusted or a 
negative leave pay item be processed at 0.00 rate. Keep in mind 
that if a negative leave pay item is processed, then the employee’s 
staff type has to be temporarily changed to not accrue leave. 

The leave was requested, approved and taken 
however leave type was incorrect.  How do I fix 
this? 

If a pay has been processed against the incorrect Earning you will 
need to do a zero pay with a negative number of hours for the 
incorrect earning and a positive number of hours for the correct 
earning 

The leave was requested, approved and taken 
however date on original request was 
incorrect. Do I need to fix and how? 

You are unable to fix this. 

What do I need to do with terminated 
employees? 

Delete their user login in Visipay.Net. 

ERROR MESSAGE 

Server Error in '/VisipayESS' Application. Runtime Error – This caused by the user being logged in for too long without 

making changes. 


