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Is there a quick way of printing together several reports from the same
document?
Step 1.

Click on the report tab of one of the reports you want to print.

Step 2.

Holding down the Ctrl key select the other reports you want to print.

Step 3.

From the File menu choose Print.
The print dialog box opens.
When multiple reports are selected the Properties button is greyed out. This is to
prevent you from overriding the different page orientations and paper sizes already
set up for the individual reports.

Step 4.

Change the target printer or select a page range and click OK.
All of the selected reports are printed on the specified printer.

Is there a way of controlling the text wrap of a cell?
You can decide where the carriage return appears in a cell that combines text and
data. This can be useful when you want to add text to a cell, heading, or master cell
and display it on more than one line.
Step 1.

Double-click on any cell in the column Expense Initial Budget.
The formula displays =<Expense Initial Budget>

Step 2.

Edit the cell formula to add text and insert the carriage return ANSI code: Char(13).
="Initial Budget : "&Char(13)& FormatNumber(<Expense Initial Budget> ,"$ 0,000.00")

Step 3.

Click outside the cell to apply the new format.

How can I display the column heading on more than one line
Step 1.

Double-click on the column heading Expense Initial Budget.
=NameOf(<Expense Initial Budget >)

Step 2.

Edit the cell formula to replace the current formula with text.
="Expense"& Char(13)&"Initial Budget"

Step 3.

Click outside the cell to apply the new format.

Tip:

You can apply these tips to format any heading with a carriage return. You can
also change the name of the heading if the variable name used in the heading is
not appropriate.

How do I combine text and data in a master cell?
When you create a master / detail report a section is created for each value of the
variable you set as the section master and this value is displayed in a master cell.
You can enhance your report by adding text, for example, to display a comment on
the value in the master cell.
Step 1.

Click in the master cell.

Step 2.

Open the Formula Bar.

Step 3.

Type some text (include a space at the end) between the quotes after the equal (=)
sign, then type the & operator.

Step 4.

Press the Enter key to display the text and data in the master cell.
Another way is to use the Concatenation function. The syntax for this function is:
 Concatenation(character string, character string)
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If you want to place a filter on the section after combining text and data in the
master cell, you'll notice that the Insert Filter button on the Standard toolbar is
unavailable.

Inserting a filter
Step 1.

Select the master cell.

Step 2.

From the Format menu select Filters.

Step 3.

Click Add.

Step 4.

Select the appropriate variable and click OK.

Step 5.

In the Values box select the values you want to filter and click OK.

Combining text and numbers
If you want to combine text with numbers using the & operator or the Concatenation
function, you must first convert the number into a character string. Otherwise,
BusinessObjects displays the error message ‘Incompatible data type’. You convert a
number to a character string by using the FormatNumber() function.
="Text: "&FormatNumber(<Measure Object> ,"0") will give you the following result:
 Text: 1 (where 1 is the value of the measure object)

Combining text and dates
If you want to combine text with dates using the & operator or the Concatenation
function, you must first convert the date into a character string. Otherwise,
BusinessObjects displays the error message 'Incompatible data type'. You can convert
a date into a character string using the FormatDate() function.
="Invoice date: "&FormatDate(<Date>, "dd/mm/yyyy") will give you the following
result
 Invoice date: 31/01/2002

How do I copy and paste formats from one cell to another?
Step 1.

Select a cell.

Step 2.

Click the Copy button on the Standard toolbar.

Step 3.

Select the cell that contains the text you want formatted.

Step 4.

Click the Paste Format button on the Standard toolbar.
Only the formatting, not the content of the cell, is copied.

Tip:

You can also use the keyboard combination Ctrl+Shift+V to paste the formatting
only.

How do I apply custom borders to tables?
Formatting the body cells
Step 1.

Select all of the body cells in the table by clicking once in the first body cell in the
first table column, holding down the Shift key and selecting a body cell in the last
table column.

Step 2.

From the Format menu choose Cell.

Step 3.

Click the Border tab.
The Border section shows a preview diagram of the borders currently applied to the
selected cells.

Step 4.
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Hold your cursor over the far left line of the preview diagram until you see arrows
appear at the top and bottom of the line.

Step 5.

Click once.
The border is removed from the preview diagram.

Step 6.

Repeat the procedure to remove other borders.

Step 7.

Choose a different line style

Step 8.

Hold your cursor over the far left line of the preview diagram until you see arrows
appear at the top and bottom of the line.

Step 9.

Click once.
The border is added to the preview diagram.

Step 10.

Click OK to close the Cell Format dialog box and apply the borders to the table.

Formatting the column header cells
Step 1.

Select empty cells only.

Step 2.

From the Format menu choose Cell.

Step 3.

Click the Border tab.

Step 4.

In the Presets section click None and then click OK.
The borders are removed from the empty table cells.

How can I easily change colours on charts?
Changing colours on a pie chart
Step 1.

Right-click on one of the pie chart slices and choose Format Data Series from the
menu.

Step 2.

On the right side of the dialog box, click on the Foreground Colour box.

Step 3.

Select a colour and click OK.

Step 4.

In the Data Series Format window select Solid (100%) from the Shading box, and click
OK.

Step 5.

Repeat for the other slices of the pie.

Tip:

You can set different colours for the foreground and background of each slice. If
you choose Clear, you apply the background colour only. If you choose Solid, you
apply the foreground colour only. You can also choose one of the other settings to
mix the two colours.

Changing colours on a column chart
Step 1.

Right-click on a column on the chart and choose Format Data Series from the menu.

Step 2.

On the right side of the dialog box click on the Foreground Colour box.

Step 3.

Select a colour from the palette and click OK.

Step 4.

Click on the Background Colour box.

Step 5.

Select a colour from the palette and click OK.

Step 6.

In the Data Series Format window select a % from the Shading box and click OK.
This setting mixes the two colours together.

How do I correctly format crosstab corners?
When you apply background shading to a section in a report that contains a crosstab,
the corner cells of the crosstab are sometimes incorrectly shaded or formatted.
Step 1.

Select the top left-hand cell of the crosstab and choose Format Cell from the Format
menu.

Step 2.

Click on the Shading tab.
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Step 3.

On the Shading tab, click the None option button in the Fill section and click OK.
This means the cell is now transparent and the section shading can show through. If
this has not solved the problem, it could be that the crosstab block has been shaded.

Step 4.

Select the crosstab and choose Format Crosstab from the Format menu.

Step 5.

Click on the Shading tab.

Step 6.

On the Shading tab, click the None option button in the Fill section.

Setting crosstab formatting in the Standard Report Styles editor in BusinessObjects
Step 1.

From the Tools menu, choose Standard Report Styles.

Step 2.

In the Report Components list, click on the plus sign next to Crosstabs.

Step 3.

Click the plus sign next to Corners.

Step 4.

Select a corner from the list.

Step 5.

Click the Shading tab, make the required settings and click OK.
This formatting will now be used every time you create a Standard report.

How do I display column titles on two lines?
Step 1.

Select the entire column header row.

Step 2.

From the Format menu choose Cell.

Step 3.

Click the Alignment tab.

Step 4.

In the Settings section tick the Wrap Text option and click OK.

Step 5.

Resize the Margin per unit column to display the column title on two lines.

Step 6.

Adjust the height of the cell containing the column title until the whole title is
correctly displayed.

Step 7.

Adjust the other columns in the table in the same way.

To align cell contents
Step 1.

Select the entire column header row.

Step 2.

From the Format menu choose Cell.

Step 3.

Click the Alignment tab.

Step 4.

In the Vertical section tick the Bottom option and in the Horizontal section tick the
Centre option

Step 5.

Click OK

How do I resize columns automatically?
Step 1.

Move the mouse cursor over the edge of the column or row.

Step 2.

When the cursor changes to the double-headed arrow resize cursor double-click.

How do I use alternate colours to shade table rows?
Setting a column background colour
Step 1.

Select all the body cells in the table columns.

Step 2.

Set the background colour.

Creating a local variable
Step 1.

Right-click on the Report Manager Data tab and choose New Variable from the menu.

Step 2.

On the Definition tab type a name in the Name box and, in the Qualification section,
choose Measure.
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Step 3.

On the Formula tab, type the following syntax:
 =Mod(LineNumber(),2)

Step 4.

Click OK.
The variable is displayed in the list in the report Manager Data tab.

Creating an alerter
Step 1.

Click in anywhere in the table and click the Alerters button on the Report toolbar.

Step 2.

Click Add.

Step 3.

On the Definition tab type in a name and add a description.

Step 4.

On the conditions tab set the following conditions:
 Set the Variable to Compare to the variable you created above.
 In the Operator 1 Box choose =.
 In the Value box choose 1.

Step 5.

In the Result box click on the arrow and choose Format from the menu.

Step 6.

In the Cell Format dialog box, click the Shading tab and set the Foreground and
Background colour to the same colour and click OK.

Step 7.

Click OK.

Step 8.

Click OK.

Using the alerter in the table
Step 1.

Select all the columns in the table and click the Alerters button on the Report
toolbar.

Step 2.

Tick the box next to the name of your alerter

Step 3.

Click OK.

Tip:

If you want to regularly use this table style include the alerter in a template.

How do I display percentage labels on a column chart?
Prepare the data
Step 1.

Create a table to display Expense Initial Budget per Branch.

Step 2.

Click in the Expense Initial Budget column and click the Insert Percentage button on
the Report toolbar.
A new column is inserted displaying the percent revenue for each branch. This is the
data you want to display in your chart. However the data in the Percentage column is
a formula. To use this data in a chart you need to define it as a variable.

Step 3.

Click in the Percentage column and, from the Data menu, choose Define as Variable.

Step 4.

In the Define the Variable dialog box type Percent revenue in the Name box, choose
the option Evaluate the formula in its context and click OK.

Step 5.

Delete the Expense Initial Budget column.
You can delete this data because you don't need it in your chart.

Display the data in a chart
Step 1.

Right-click on the table and choose Turn to Chart from the menu.

Step 2.

In the Chart Types list choose Column and click OK.

Step 3.

Right-click on the chart columns and choose Insert Data Labels from the menu.

Step 4.

In the Data Labels dialog box choose Show Value.
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A value is displayed above each column in the chart; however it is not yet correctly
formatted.

Format the values correctly as percentages
Step 1.

Select the values above the chart columns and click the Percentage Style button on
the Formatting toolbar.

Step 2.

Select the values on the Y-axis and click the Percentage Style button on the
Formatting toolbar.

How do I copy and paste data from BusinessObjects to Excel?
Step 1.

Select a table in BusinessObjects.

Step 2.

From the Edit menu choose Copy All.

Step 3.

Open the Microsoft Excel workbook where you want to paste your data.

Step 4.

From the Edit menu choose Paste Special.

Step 5.

Choose one of the following options and click OK.
Choose

To

 Text

Copy the clipboard contents as data that you can then
work on in Excel.

 Picture

Copy the clipboard contents as a Picture image. You will
not be able to work on the data.

 Bitmap

Copy the clipboard contents as a Bitmap image. This
format can take up a lot of memory and disk space.

How do I export data from BusinessObjects to Excel and keep the
BusinessObjects report formatting?
Step 1.

From the File menu choose Save as HTML.

Step 2.

Click Save.

Step 3.

Set the required options and click OK.

Step 4.

Open Microsoft Excel.

Step 5.

Open the BusinessObjects UserDocs folder.
When you save a report in HTML format, BusinessObjects creates a number of files
and folders. The top-level folder is given the same name as the BusinessObjects
document.
The HTML file opens in Excel. If your report contains tables, charts and images you
may need to re-arrange the elements in your Excel workbook as an image can
sometimes overlap a table.

Step 6.

Save the file as an Excel file.
In Excel you can change cell formatting, borders, backgrounds and fonts. You can
select a cell and change the contents and even carry out calculations on the data in
the tables. However Charts are saved as images so you will not be able to edit them
in the Excel chart editor.

How do I use a split window to view reports more easily on screen?
If you have a very long or a very wide table containing a lot of data, you can make it
easier for users to view it on screen by splitting the BusinessObjects report window
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into two panes. In one pane, you can position the column or row titles and use the
second pane to scroll through the table data.
Step 1.

Make sure that you are not in Page Layout view.

Step 2.

From the Window menu, choose Split.
A horizontal and a vertical guideline are displayed in the report window. You use
these guides to determine where you want to split the report window.

Step 3.

Drag the horizontal guideline to the very bottom of the report window and click once
to remove it.

Step 4.

Drag the vertical guide dividing the two panes and place it over the right edge of the
first table column that contains the row titles.

How can I format a chart quickly
Right-Click

To

On the pop-up menu select

 Anywhere in the chart

Switch to a different type of chart.

AutoFormat

Display the chart as a table.

Turn to Table

Insert a legend or a title

Insert Legend Insert Title

Insert a legend or a title

Insert Legend Insert Title

Display or hide axes or gridlines

Display Axes/Gridlines

Sort or filter data in the chart

Edit Sorts

 A blank space in the chart

Edit Filters
 The chart's outer border

 A specific element e.g. an
axis

Cut, copy or delete the chart

Cut/Copy/Delete

Change the chart's name, pagination,
alignment, contents, borders and
shading

Format Chart

Hide or show chart walls

Edit Chart

Display data on two Y-axes

Edit Chart

Display up-down bars, high-low lines
or drop lines

Edit Chart

Change the chart's name, pagination,
alignment, contents, borders and
shading

Format Chart

Change the element's colour, shade,
alignment etc

Format Element e.g. Format
Axis Label

How can I make WebIntelligence documents easier to navigate?
If you have organized your query into sections WebIntelligence lets you incorporate a
navigation bar within a document so that you can navigate easily from section to
section. The navigation bar displays a hyperlinked index of section names that allows
you to quickly go to the area you're interested in.
Example: Viewing the document by branch.
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Step 1.

In the Web panel click and drag the Branch object to the Section panel.

Step 2.

Click the Settings tab.

Step 3.

Click inside the Section preview area (not on the Section title).

Step 4.

Tick the Show as Index option.

Step 5.

Click Apply Format.

Step 6.

Click a branch name to view another branch.

How do I lay out a long, narrow table to use page space more efficiently
If you have a table containing three narrow columns of data that extends over
several pages it can leave a lot of unused space on a page. By setting one option, you
can lay out this table differently to use the entire width of the page and reduce the
number of pages to view or print.

Format the table layout
Step 1.

Make sure you are in Page Layout view.

Step 2.

Right-click on the table and choose Format Table from the menu.

Step 3.

Click the General tab.

Step 4.

In the Columns section set a number in the Columns box and a number in the Spacing
box.

Step 5.

Click OK.

Tip:

If your table orientation is set to across, rows are displayed instead of columns.

Add heading row titles
Step 1.

Right-Click on the table and choose Format Table from the menu

Step 2.

Click the Page Layout tab.

Step 3.

Tick the option Page break header after page break.

Step 4.

Click OK.

How do I use subqueries to build queries with different aggregation levels?
Sometimes you need to answer business questions that involve aggregating data on
more than one level. This can occur when:
 The query result contains aggregated data
and
 The query contains a condition that aggregates at a different level from the
aggregation in the result
An example of this is: list the branches and their associated Expense Initial Budgets
of all Directorates whose total Expense Initial Budgets is >= $1,000,000. In this case
the result must show Expense Initial Budget aggregated by branch while the condition
determining which branches appear in the result involves aggregating by directorate.
The best way to solve problems like this is to use a subquery. The main query
aggregates at the level necessary to display the report, while the subquery
aggregates at the level necessary to evaluate the condition.
Step 1.

Drag the Branch and Expense Initial Budget objects into Result Objects pane.

Step 2.

Drag the Directorate object into the Conditions pane.

Step 3.

Double-click In list in the list of operators.

Step 4.

Double-click Create a subquery in the list of operands.

Step 5.

Drag the Directorate object to the Result Objects pane.
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Step 6.

Drag the Expense Initial Budget object to the Conditions pane.

Step 7.

Double-click Greater than or equal to in the list of operators.

Step 8.

Double-click Type a new constant in the list of operands.

Step 9.

Type 1000000 next to Expense Initial Budget greater than or equal to.

Step 10.

Run the query.

How do I include a user response to a query prompt in a report title?
When you create BusinessObjects reports you often set up prompts so that report
users can choose which data they wish to retrieve from the database and view in the
report.
A common request is for the report title to include the value the user specified at
the prompt so that report users can see at a glance which branch, for example, the
report data pertains to. You can do this by setting up a formula using the
UserResponse function.
You first need to set up a query with conditions that prompt users to choose which
data they wish to retrieve from the database when they run or refresh the report.
In this example, you have set up a report to display Expense Initial Budget figures
that prompts users to choose the branch; only data pertaining to the chosen branch
is retrieved from the database and displayed in the report.

Include this information in the report title
Step 1.

From the Insert menu, choose Special Field and then Query Prompt.

Step 2.

Choose the prompt Which Branch? and click OK.

Step 3.

Click once where you want the query prompt to be displayed.
The branch you chose at the query prompt is displayed in the cell.
If you refresh the report and chose a different branch the contents of the cell are
updated with the new branch.

How do I display the logo in a WebIntelligence Document?
You can add the logo in any of the page labels of a WebIntelligence document.
To make sure that the logo appears no matter who views the document or which
computer they use, use an image file located on the server in a shared folder or a
virtual directory. If you use a file located on your computer the logo will not appear
in the document when other users view it from another computer.
Step 1.

Select the Settings tab to view the Document Settings options.

Step 2.

Click Add Page Label from the document settings options.

Step 3.

Select the new Page Label and enter the image path in the Text field of the Page
Label Settings.
You can use one of the following two methods for the path:
 <img src="http://ServerName/FolderName/FileName.bmp">
 <img src="file://DriveName\FolderName\FileName.bmp ">

Tip:

The image file-type for the logo can be a .jpg, .jpeg, .bmp, or .gif file.

How do I include a background image in a WebIntelligence document?
The image should be located in a shared file or virtual directory on the
WebIntelligence server. If the image file is located on a local computer others will
not be able to view the image from their computers.
Step 1.
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Click the Edit Data provider icon on the Standard toolbar to go to the Query Panel.

Step 2.

Select the Settings Tab to add the background picture to your document.

Step 3.

In the Image text box in the top left of the Document Settings tab, enter the path of
the document that you want to appear in the background of the document.
To display the image use one of the following syntax options:
 file://DriveName\FolderName\FileName.bmp
 http://ServerName/FolderName/FileName.bmp.
The path must lead to a file located in a shared folder or directory on the
WebIntelligence Server.

Step 4.

Click Run Query to view the result.

How do I include links to files from a WebIntelligence document?
You can include links to .htm files, images and web sites in your WebIntelligence
document.
The Universe Designer creates the data objects containing the links. All you have to
do is add the objects to your selection in the Web Panel and run the query.

Creating a Query with Hyperlinks
Step 1.

Click the Edit Data provider icon on the Standard toolbar to go to the Query Panel.

Step 2.

Select the objects you want to include in the query, including the objects linked to
the images.

Step 3.

Click Run Query to view the results.
You now have a dynamic document that contains links to more detailed information.
All of this data is linked to the document without having to query the repository for
new information. Using this process allows you to provide information without taxing
your system with unnecessary data requests.

How do I share reports with users who do not have BusinessObjects or
WebIntelligence?
BusinessObjects allows you to save a BusinessObjects document or report in a
number of different formats. This means that you can share the results of your
analysis with users who do not have BusinessObjects or WebIntelligence, either by
posting documents on an intranet or web site or by sending a document directly to a
user.
BusinessObjects allows you to save a BusinessObjects document in the following
industry-standard formats:
 HTML
 PDF (Adobe Acrobat Portable Document Format)
 Text
 RTF (Rich Text Format)
 Export or copy and paste data to Excel

HTML format
Step 1.

From the File menu choose Save As HTML.

Step 2.

Choose the location where you want to save the file and click Save.
When you save a document in HTML format, BusinessObjects creates a number of
files and folders. These files and folders manage graphics, saved as .gif files,
navigation, downloading, frames and multiple reports in the same document.
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PDF format
All you need to view and print PDF documents is the free Adobe Acrobat Reader.
When you open a BusinessObjects document saved in PDF format you can view and
navigate through different reports but you cannot edit, analyse or refresh the data.
All reports in a BusinessObjects document are saved in one PDF document and a
navigation outline is retained making it easy to navigate quickly through reports and
report sections within the PDF version. This format also allows you to obtain high
quality printed copies.
Step 1.

From the File menu choose Save As.

Step 2.

In the Save as type list box choose the PDF format and click Save.

RTF or text format
When you save a BusinessObjects document in text (.txt) or Rich Text Format (.rtf),
only the currently selected report is saved. Graphics are not saved in rich text format
and text documents.
Step 3.

From the File menu choose Save As.

Step 4.

In the Save as type list box choose the RTF format and click Save.
BusinessObjects makes a copy of the document and saves it in the specified format.
The original document remains on your screen.

Export or copy and paste data to Excel
You can also export the data contained in a document to an Excel spreadsheet or
copy and paste tables and charts from BusinessObjects to Excel. This is explained in
the answer to the question “How do I export data from BusinessObjects to Excel and
keep the BusinessObjects report formatting?”.

How do I send reports to other users?
Step 1.

Open the report in BusinessObjects, then select one of the following commands from
the File menu:
 Send To>Users

Send the report to individual users. When they receive
the report, they remove it from the repository

 Send To>Repository

Send the report to groups of users. The report stays in
the repository until the administrator removes it.

 Send To>Document
Agent Server

Distribute the report using Document Agent Server,
which can also refresh, print and web publish reports.

 Send to>Mail

Send reports by email.

Step 2.

Specify the user(s) or group(s) of users you want to send the report to.

Step 3.

Click Send.
BusinessObjects notifies users when they receive reports. The Retrieve From
command on the File menu lets users download reports from the repository to their
PC.
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